컴퓨터 시스템의 구성과 기능 


1. 컴퓨터 구성요소


1. 컴퓨터 시스템의 구성

- 하드웨어

       하드와이어 프로그램 

- 소프트웨어

- 펌웨어(소프트웨어를 하드웨어화 시킨 것) 


2. 소프트웨어 

- 시스템 소프트웨어(OS)

- 응용 소프트웨어 


3, 시스템 소프트웨어


4. 운영체제의 기능

- 컴퓨터 내의 하드웨어/소프트웨어 자원 관리

   - 프로세스 관리

   - 주기억 장치 관리

   - 보조기억 장치의 사용 관리

   - 입출력 장치 관리

   - 파일 관리

- 사용자에게 인터페이스 제공

- 장지 고장을 탐색, 오류 처리, 보안 유지


5. 소프트웨어

- 유틸리티

- 장치 드라이버

- 컴퓨터 프로그래밍 언어 


6. 응용 소프트웨어


7. 펌웨어 (ROM에 들어있는 기본 프로그램) 


8. 하드웨어 

- 중앙처리장치

- 기억장치

- 입출력장치


9. 중앙처리를 구성하는 하드웨어 


10. 컴퓨터 내부 구조와 자료, 명령 신호 흐름 

 


2. 컴퓨터 기능


1. 기능 : 프로그램 실행과 제어, 데이터 입출력, 데이터 이동과 저장


2. 명령어 수행 과정 : 프로그램 처리과정, 명령어 수행과정, 두개의 사이클 


3. 레지스터 : CPU내의 임시 기억 장치, 컴퓨터 내부 구성에서의 저장 장치


4. CPU내의 레지스터 : PC, IR, MAR, MBR, I/0 AR, I/0 BR 


5. 정보의 표현과 컴퓨터 언어 : 저급 언어, 어셈블리 언어, 고급 언어  


6. 명령어 사이클 : 인출 사이클, 실행 사이클 


7. 인출 사이클과 실행 사이클


3. 버스와 상호 연결 


1. 개요 : 버스, 버스를 통해 전송되는 유형, 시스템 버스 


2. 시스템 버스 : 데이터 버스, 제어 버스


3. CPU와 기억장치간의 데이터 이동 : 양방향성, 단방향성 


4. 기억장치 엑세스간의 시간 흐름 : 기억장치 쓰기시간, 읽기시간 


5. 시스템 버스를 통한 구성장치의 연결 : 장치 드라이버 내의 상태 레지스터, 데이터 레지스터, 제어기 



























데이터 표현 


1. 산술 논리 연상장치


- 중앙처리장치의 구성 : 산술논리연산장치, 레지스터, 제어장치 

- ALU 내부 구성 요소 : 산술 연산장치, 논리 연산장치, 시프트 레지스터, 보수기, 상태 레지스터 


2. 진법과 진법 변환


- 10진수, 2진수, 16진수 


3. 데이터의 표현 


- 10진수의 표현 : 존 형식(한자리 1바이트), 팩 형식(두자리 1바이트) 

- 정수의 표현 (0, 1, 부호 및 소수점)

- 소수의 표현 (2곱해서 .00나올떄까지 올림수) 

- 음수의 표현

- 부동소수점 표현

- 문자 데이터 (BCD, ASCII, EBCDIC) 

- 한글코드의 종류 


4. 산술연산 


- 정수의 산술 : 음수화, 덧셈, 뺼셈, 곱셈, 나눗셈 

Given a time in -hour AM/PM format, convert it to military (-hour) time.

Note: Midnight is  on a -hour clock, and  on a -hour clock. Noon is  on a -hour clock, and  on a -hour clock.

Input Format

A single string containing a time in -hour clock format (i.e.:  or ), where  and .

Output Format

Convert and print the given time in -hour format, where .

Sample Input

07:05:45PM

Sample Output

19:05:45

 

Colleen is turning  years old! Therefore, she has  candles of various heights on her cake, and candle  has height . Because the taller candles tower over the shorter ones, Colleen can only blow out the tallest candles.

Given the  for each individual candle, find and print the number of candles she can successfully blow out.

Input Format

The first line contains a single integer, , denoting the number of candles on the cake. 
The second line contains  space-separated integers, where each integer  describes the height of candle .

Constraints

Output Format

Print the number of candles Colleen blows out on a new line.

Sample Input 0

4
3 2 1 3

Sample Output 0

2

Explanation 0

We have one candle of height , one candle of height , and two candles of height . Colleen only blows out the tallest candles, meaning the candles where . Because there are  such candles, we print  on a new line.

 

 

 


두번 for문 쓰지 않고


한번에 비교하면서 카운트 하기 


(max 변화시 sum 다시 1로 초기화)



  public static void main(String[] args) {

  

        Scanner in = new Scanner(System.in);

        int n = in.nextInt();

        

        int max = 0;

        int sum = 0;

        int num;

        

        for(int i =0; i < n; i++){

            num = in.nextInt();

            

            if(num > max){

                sum = 1;

                max = num;

            }else if(num == max){

                sum++;

            }

        }

        System.out.println(sum);

    }


Given five positive integers, find the minimum and maximum values that can be calculated by summing exactly four of the five integers. Then print the respective minimum and maximum values as a single line of two space-separated long integers.

Input Format

A single line of five space-separated integers.

Constraints

  • Each integer is in the inclusive range .

Output Format

Print two space-separated long integers denoting the respective minimum and maximum values that can be calculated by summing exactly four of the five integers. (The output can be greater than 32 bit integer.)

Sample Input

1 2 3 4 5

Sample Output

10 14

Explanation

Our initial numbers are , and . We can calculate the following sums using four of the five integers:

  1. If we sum everything except , our sum is .
  2. If we sum everything except , our sum is .
  3. If we sum everything except , our sum is .
  4. If we sum everything except , our sum is .
  5. If we sum everything except , our sum is .

As you can see, the minimal sum is  and the maximal sum is . Thus, we print these minimal and maximal sums as two space-separated integers on a new line.

Hints: Beware of integer overflow! Use 64-bit Integer.


 



복잡하게 품..


밑에 처럼 최대 최소값을 함수로 찾고 


최대 최소값 뺀 후 더하는 것 보다 


sum에서 빼는게 빠르다!!!!




        long sum = 0;

        long min = Long.MAX_VALUE;

        long max = Long.MIN_VALUE;

        

        Scanner scanner = new Scanner(System.in);

        for (long i = 0; i < 5; i++) {

            long n = scanner.nextLong();

            sum += n;

            min = Math.min(n, min);

            max = Math.max(n, max);

        }

        System.out.println((sum - max)+" "+(sum - min));






+ Recent posts