You are given an array of integers of size . You need to print the sum of the elements in the array, keeping in mind that some of those integers may be quite large.

Input Format

The first line of the input consists of an integer . The next line contains  space-separated integers contained in the array.

Output Format

Print a single value equal to the sum of the elements in the array.

Constraints 
 

Sample Input

5
1000000001 1000000002 1000000003 1000000004 1000000005

Output

5000000015

Note:

The range of the 32-bit integer is .

When we add several integer values, the resulting sum might exceed the above range. You might need to use long long int in C/C++ or long data type in Java to store such sums.




Alice and Bob each created one problem for HackerRank. A reviewer rates the two challenges, awarding points on a scale from  to  for three categories: problem clarityoriginality, and difficulty.

We define the rating for Alice's challenge to be the triplet , and the rating for Bob's challenge to be the triplet .

Your task is to find their comparison points by comparing  with  with , and  with .

  • If , then Alice is awarded  point.
  • If , then Bob is awarded  point.
  • If , then neither person receives a point.

Comparison points is the total points a person earned.

Given  and , can you compare the two challenges and print their respective comparison points?

Input Format

The first line contains  space-separated integers, , and , describing the respective values in triplet 
The second line contains  space-separated integers, , and , describing the respective values in triplet .

Constraints

Output Format

Print two space-separated integers denoting the respective comparison points earned by Alice and Bob.

Sample Input

5 6 7
3 6 10

Sample Output

1 1 

Explanation

In this example:

Now, let's compare each individual score:

  • , so Alice receives  point.
  • , so nobody receives a point.
  • , so Bob receives  point.

Alice's comparison score is , and Bob's comparison score is . Thus, we print 1 1 (Alice's comparison score followed by Bob's comparison score) on a single line.

 

 

 

 

 

다른사람 풀이를 보니..

 

나는 구지 배열을 남발하며 꾸역꾸역 비교하였구나.. ㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎㅎ

 

이리 간단한것을..........ㅎ


 

public class Solution {


public static void main(String[] args) {

Scanner in = new Scanner(System.in);

int a0 = in.nextInt();
int a1 = in.nextInt();
int a2 = in.nextInt();
int b0 = in.nextInt();
int b1 = in.nextInt();
int b2 = in.nextInt();
int a = 0;
int b = 0;
if (a0 > b0) a++;
if (a0 < b0) b++;
if (a1 > b1) a++;
if (a1 < b1) b++;
if (a2 > b2) a++;
if (a2 < b2) b++;
System.out.println(a + " " + b);
}
}

 

 

조합 및 순서 논리회로


1. 디지털 논리회로


1. 회로


- 아날로그 회로 : 자연계에서 일어나는 물리적인 양은 시간에 따라 연속적으로 변화함 (온도, 습도, 소리, 빛)


- 디지털 회로 : 확연히 구별되는 두 레벨의 신호값 만을 가짐(0, 1)


* 아날로그 신호를 샘플링을 통해 디지털 신호로 변환 할 수 있다. 


2. 디지털 논리 회로


: 디지털 신호(불연속적 신호)로 나타낸 정보를 처리하는 회로, 논리연산을 하는 회로


- 기본적인 논리회로 : NOT, AND, OR


- 디지털 회로 


* 조합 논리 회로 : 출력 값은 입력 값에 의해서만 결정 

      * 순차 논리 회로 : 출력 값은 회로의 상태(기억된 정보)입력 값에 의해 결정 ,  Flip Flop 


2. 조합 논리회로


1. 정의 : 출력 값은 입력 값에 의해서만 결정, 메모리를 갖지 않는 회로 


2. 설계 방법 : 진리표, 진리표로 카르노 도표, 간소화된 논리식, 논리식을 기본 게이트로 구성 

 

3. 가산기 : 두 개 이상의 입력을 이용하여 이들의 합을 출력하도록 하는 조합 논리 회로 



4. 반가산기 : 두 개의 입력과 출력 합과 올림수가 사용  


* 경량화, 최소화, 경제적 : 카르노맵의 부울 대수식 


- 계산법과 진리표 

- 올림수와 합에 대한 부울 대수식

- 반가산기의 논리회로


5. 전가산기 : 두 입력과 하나의 올림수를 사용하여 더셈 수행 


- 계산법과 진리표 

- 올림수와 합에 대한 부울 대수식

- 전가산기의 논리회로


6. 멀티플렉서 : 여러 개의 입력선 중 하나의 입력선 만을 출력에 전달해주는 조합 논리회로


7. 디멀티플렉서 : 멀티플렉서의 역기능을 수행, 선택선이 N개인 경우 2의n제곱 개의 출력선이 존재 


3. 순차 논리회로 


1. 정의 : 조합 논리 회로와 flipflop을 가지고 구성, 출력 값은 입력 값과 회로의 내부 상태에 의해 결정 

2, 플립플롭 


- RS플립플롭, D플립플롭, T플립플롭, JK플립플롭 


















게임 스토리 텔링



1교시. 게임 스토리


1. 게임 스토리 


2. 세계관의 선정 기준 


1) 세계관이란


2) 세계관의 기능


3) 세계관의 구분


4) 세계관에 들어가는 요소



2교시. 게임 세계관 분석

      

       1. 시대(시간)분석


2. 장소 분석


3. 사회 규범


4. 가와베 가즈토의 체크리스트


5. 삼국지의 세계관 분석 



3교시. 게임 스토리 텔링


1. 게임 스토리 텔링


1) 게임 스토리


2) 게임 플레이어의 욕구


2. 게임 스토리 텔링의 형식 


1) 스토리 구성 : 선형 스토리 형식, 비선형 스토리 형식, 거미망 형태의 스토리 형식


3. 게임 스토리 텔링의 타입별 형식 




Given an array of  integers, can you find the sum of its elements?

Input Format

The first line contains an integer, , denoting the size of the array. 
The second line contains  space-separated integers representing the array's elements.

Output Format

Print the sum of the array's elements as a single integer.

Sample Input

6
1 2 3 4 10 11

Sample Output

31

Explanation

We print the sum of the array's elements, which is: .





 

+ Recent posts